本帖最后由 米拿现’ 于 2013-5-29 19:15 编辑

# yum install libxslt
# yum install libxslt-devel   这两个对编译xsl 环境 要求 非常重要,不然编译的时候会出现错误

下载php-5.2.17.tar.gz
tar zxvf php-5.2.17.tar.gz
cd php-5.2.17
cd ext/xsl
/usr/local/php/bin/phpize   (对应的phpize路径)(安装好的php位置)
configure –with-php-config=/usr/local/php/bin/php-config (对应的php-config路径(php-config文件名不能更改)
make
make install
出现提示
//此时会在 哪个目录下 下生成一个xsl.so文件,如有同名的,覆盖之。
然后修改php.ini的文件
extension_dir=/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626"(对应的extensions路径)
extension = xsl.so

——————————————–
第二种方法:

安装扩展xsl
找到安装包

find -name php-5.2.17*

进入安装包所在目录

如果是压缩的执行下边这条指令,已经解压缩的就跳过进入下一条指令

tar zxvf  php-5.2.17.tar.gz

cd php-5.2.17/ext/xsl

/usr/local/php_fcgi/bin/phpize

./configure –with-php-config=/usr/local/php_fcgi/bin/php-config

make

make install

出现提示

然后修改php.ini的文件
[memcache]
extension_dir="/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/"
extension = "memcache.so"
output_buffering = On

[mysqli]
extension_dir="/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626"
extension = "mysqli.so"

[xsl]
extension_dir="/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626"
extension = "xsl.so"

发表评论

电子邮件地址不会被公开。 必填项已用*标注